Apogee

collapse expand iconDescription

The Apogee MEQ-5 Midrange Equalizer plug-in is modeled to reproduce every nuance of the Pultec Midrange Equalizer. The Pultec MEQ-5 plug-in precisely recreates the original hardware to sculpt critical midrange frequencies with all the warmth you'd expect from this classic EQ. With FX and FX Rack versions included, the MEQ-5 plug-in runs natively in your favorite DAW on Mac or Windows with no Apogee hardware required. It also runs on Apogee hardware DSP in Element Series and Ensemble Thunderbolt audio interfaces. Additional features include DualPath Monitoring for near zero latency recording.
Apogee MEQ-5 Midrange Equalizer Plug-in

collapse expand iconFeatures

  • Developed with Pulse Techniques, current manufacturer of hardware Pultec EQs
  • Apogee plugin modeled from brand new Pultec unit
  • Officially licensed and endorsed by Pulse Techniques

collapse expand iconSpecs

System Requirements
  • Operating System: macOS
  • Supported Plugins: VST-2, VST-3, AU, AAX
  • Operating System: Windows
  • Supported Plugins: VST-2, VST-3, AAX

Featured Articles