Apogee

collapse expand iconDescription

The Apogee FX Rack Pultec bundle plug-in was created after careful analysis of several vintage and new Pultec units. In an effort to reproduce every nuance of the Pultec Program Equalizer and the Pultec Midrange Equalizer, this plug-in bundle is like unboxing a brand new unit in 1959.

collapse expand iconSpecs

Included:
  • Pultec EQP-1A
  • Pultec MEQ-5
System Requirements:
  • Operating System: macOS
  • Supported Plugins: VST-2, VST-3, AU, AAX
  • Operating System: Windows
  • Supported Plugins: VST-2, VST-3, AAX

Featured Articles